#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\h+\K[А-Яа-я]+(?=\h+[А-Яа-я]+$)"
Local $sString = "Иванов Иван Иванович" & @CRLF & _
"1337 Иванов Иван Иванович" & @CRLF & _
"Альбертов Николай Петрович" & @CRLF & _
"$#$@$$@$@# Иванов Иван Иванович"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")