re = /^.*?\h+\K[А-Яа-я]+(?=\h+[А-Яа-я]+$)/m
str = 'Иванов Иван Иванович
1337 Иванов Иван Иванович
Альбертов Николай Петрович
$#$@$$@$@# Иванов Иван Иванович'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end