$re = '/^.*?\h+\K[А-Яа-я]+(?=\h+[А-Яа-я]+$)/m';
$str = 'Иванов Иван Иванович
1337 Иванов Иван Иванович
Альбертов Николай Петрович
$#$@$$@$@# Иванов Иван Иванович';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);