const regex = /^.*?\h+\K[А-Яа-я]+(?=\h+[А-Яа-я]+$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\h+\\K[А-Яа-я]+(?=\\h+[А-Яа-я]+$)', 'mg')
const str = `Иванов Иван Иванович
1337 Иванов Иван Иванович
Альбертов Николай Петрович
\$#\$@\$\$@\$@# Иванов Иван Иванович`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}