using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ITEM1\.([\s\S]*?)ITEM1A\.";
string input = @"ITEM1.BUSINESS (Dollars in thousands) General AAR CORP. and its subsidiaries are referred to herein collectively as ""AAR,"" ""Company,"" ITEM1A.RISK FACTORS The following is a description of some of the principal risks inherent in our business. ITEM1A. some other text ITEM2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}