$re = '/ITEM1\.([\s\S]*?)ITEM1A\./m';
$str = 'ITEM1.BUSINESS (Dollars in thousands) General AAR CORP. and its subsidiaries are referred to herein collectively as "AAR," "Company," ITEM1A.RISK FACTORS The following is a description of some of the principal risks inherent in our business. ITEM1A. some other text ITEM2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);