const regex = new RegExp('ITEM1\\.([\\s\\S]*?)ITEM1A\\.', 'gm')
const str = `ITEM1.BUSINESS (Dollars in thousands) General AAR CORP. and its subsidiaries are referred to herein collectively as "AAR," "Company," ITEM1A.RISK FACTORS The following is a description of some of the principal risks inherent in our business. ITEM1A. some other text ITEM2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}