import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ITEM1\\.([\\s\\S]*?)ITEM1A\\.";
final String string = "ITEM1.BUSINESS (Dollars in thousands) General AAR CORP. and its subsidiaries are referred to herein collectively as \"AAR,\" \"Company,\" ITEM1A.RISK FACTORS The following is a description of some of the principal risks inherent in our business. ITEM1A. some other text ITEM2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}