#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\*)([\s\S]+?)\1"
Local $sString = "*Kursiv-Text*" & @CRLF & _
"" & @CRLF & _
"*Kursiver, " & @CRLF & _
"mehrzeiliger Text*" & @CRLF & _
"" & @CRLF & _
"# Kursiver *Text* in Überschrift"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")