using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\*)([\s\S]+?)\1";
string input = @"*Kursiv-Text*
*Kursiver,
mehrzeiliger Text*
# Kursiver *Text* in Überschrift";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}