$re = '/(\*)([\s\S]+?)\1/';
$str = '*Kursiv-Text*
*Kursiver,
mehrzeiliger Text*
# Kursiver *Text* in Überschrift';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);