re = /(\*)([\s\S]+?)\1/
str = '*Kursiv-Text*
*Kursiver,
mehrzeiliger Text*
# Kursiver *Text* in Überschrift'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end