#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#(?P<key>[^#]+)#(?P<values>(?:(?!^#)[\s\S])+)"
Local $sString = "#first#Cat Dog" & @CRLF & _
"Fox" & @CRLF & _
"#second#Table Window" & @CRLF & _
"#third#Apple Orange" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")