re = /^#(?P<key>[^#]+)#(?P<values>(?:(?!^#)[\s\S])+)/m
str = '#first#Cat Dog
Fox
#second#Table Window
#third#Apple Orange
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end