$re = '/^#(?P<key>[^#]+)#(?P<values>(?:(?!^#)[\s\S])+)/m';
$str = '#first#Cat Dog
Fox
#second#Table Window
#third#Apple Orange
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);