using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#(?P<key>[^#]+)#(?P<values>(?:(?!^#)[\s\S])+)";
string input = @"#first#Cat Dog
Fox
#second#Table Window
#third#Apple Orange
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}