#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\/$|^\/fr|^\/page)(\/\w*)*$"
Local $sString = "/" & @CRLF & _
"/page" & @CRLF & _
"/page/" & @CRLF & _
"/page/1234" & @CRLF & _
"/fr" & @CRLF & _
"/fr/" & @CRLF & _
"/fr/test" & @CRLF & _
"/" & @CRLF & _
"" & @CRLF & _
"/frant" & @CRLF & _
"/franythingafter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")