re = /^(\/$|^\/fr|^\/page)(\/\w*)*$/m
str = '/
/page
/page/
/page/1234
/fr
/fr/
/fr/test
/
/frant
/franythingafter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end