import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/$|^\\/fr|^\\/page)(\\/\\w*)*$";
final String string = "/\n"
+ "/page\n"
+ "/page/\n"
+ "/page/1234\n"
+ "/fr\n"
+ "/fr/\n"
+ "/fr/test\n"
+ "/\n\n"
+ "/frant\n"
+ "/franythingafter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}