$re = '/^(\/$|^\/fr|^\/page)(\/\w*)*$/m';
$str = '/
/page
/page/
/page/1234
/fr
/fr/
/fr/test
/
/frant
/franythingafter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);