#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(the|my) .*?(?P<bar>\w+) Foo"
Local $sString = "FooFooFoo the FooFoo the Bar Foo" & @CRLF & _
"FooFooFoo the FooFoo my Bar Foo" & @CRLF & _
"" & @CRLF & _
"FooFooFoo my FooFoo my Bar Foo" & @CRLF & _
"FooFooFoo my FooFoo the Bar Foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")