using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(the|my) .*?(?P<bar>\w+) Foo";
string input = @"FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}