// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(the|my) .*?(?P<bar>\w+) Foo").unwrap();
let string = "FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}