#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[4-9]|\d\d+)(?:\.\d+){3}|3\.[2-9]\d(?:\.\d+){2}|3\.1[1-9](?:\.\d+){2}|3\.10\.[1-9]\d?\.\d+$"
Local $sString = "3.10.1.0" & @CRLF & _
"3.10.2.0" & @CRLF & _
"3.10.13.1" & @CRLF & _
"3.11.0.0" & @CRLF & _
"3.11.2.0" & @CRLF & _
"3.20.0.0" & @CRLF & _
"4.0.0.0" & @CRLF & _
"5.0.0.0" & @CRLF & _
"10.0.0.0" & @CRLF & _
"3.10.0.0" & @CRLF & _
"3.9.0.0" & @CRLF & _
"3.1.0.0" & @CRLF & _
"3.0.0.0" & @CRLF & _
"2.0.0.0" & @CRLF & _
"1.0.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")