import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[4-9]|\\d\\d+)(?:\\.\\d+){3}|3\\.[2-9]\\d(?:\\.\\d+){2}|3\\.1[1-9](?:\\.\\d+){2}|3\\.10\\.[1-9]\\d?\\.\\d+$";
final String string = "3.10.1.0\n"
+ "3.10.2.0\n"
+ "3.10.13.1\n"
+ "3.11.0.0\n"
+ "3.11.2.0\n"
+ "3.20.0.0\n"
+ "4.0.0.0\n"
+ "5.0.0.0\n"
+ "10.0.0.0\n"
+ "3.10.0.0\n"
+ "3.9.0.0\n"
+ "3.1.0.0\n"
+ "3.0.0.0\n"
+ "2.0.0.0\n"
+ "1.0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}