re = /^(?:[4-9]|\d\d+)(?:\.\d+){3}|3\.[2-9]\d(?:\.\d+){2}|3\.1[1-9](?:\.\d+){2}|3\.10\.[1-9]\d?\.\d+$/m
str = '3.10.1.0
3.10.2.0
3.10.13.1
3.11.0.0
3.11.2.0
3.20.0.0
4.0.0.0
5.0.0.0
10.0.0.0
3.10.0.0
3.9.0.0
3.1.0.0
3.0.0.0
2.0.0.0
1.0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end