# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[4-9]|\d\d+)(?:\.\d+){3}|3\.[2-9]\d(?:\.\d+){2}|3\.1[1-9](?:\.\d+){2}|3\.10\.[1-9]\d?\.\d+$"
test_str = ("3.10.1.0\n"
"3.10.2.0\n"
"3.10.13.1\n"
"3.11.0.0\n"
"3.11.2.0\n"
"3.20.0.0\n"
"4.0.0.0\n"
"5.0.0.0\n"
"10.0.0.0\n"
"3.10.0.0\n"
"3.9.0.0\n"
"3.1.0.0\n"
"3.0.0.0\n"
"2.0.0.0\n"
"1.0.0.0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.