# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\b(PAL)\s?(\d+)\b.*/$1$2/mg;t' <<< "TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT
TCNU1573105 HDPE HTA108 155 155 000893520918 PAL 990 25.2750 MT 28.9750 MT"