re = /.*\b(PAL)\s?(\d+)\b.*/m
str = 'TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT
TCNU1573105 HDPE HTA108 155 155 000893520918 PAL 990 25.2750 MT 28.9750 MT'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result