package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b(PAL)\s?(\d+)\b.*`)
var str = `TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT
TCNU1573105 HDPE HTA108 155 155 000893520918 PAL 990 25.2750 MT 28.9750 MT`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}