use strict;
my $str = 'TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT
TCNU1573105 HDPE HTA108 155 155 000893520918 PAL 990 25.2750 MT 28.9750 MT';
my $regex = qr/.*\b(PAL)\s?(\d+)\b.*/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";