package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/shop-feature\/`)
var str = `https://example.com/shop-feature/?firstname=John&lastname=Doe`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}