re = /\/shop-feature\//
str = 'https://example.com/shop-feature/?firstname=John&lastname=Doe'
# Print the match result
str.match(re) do |match|
puts match.to_s
end