const regex = /\/shop-feature\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/shop-feature\\\/', '')
const str = `https://example.com/shop-feature/?firstname=John&lastname=Doe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}