$re = '/\/shop-feature\//';
$str = 'https://example.com/shop-feature/?firstname=John&lastname=Doe';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);