using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w_]+)(?:\{([^}]*)\})?\s+([\d\\.e+-]+)(?:\s+(\d+))?$";
string input = @"machine_npu_nums 8
npu_chip_info_aicore_current_freq{container_name="",id=""1"",model_name=""910B2-Ascend-V1"",namespace="",pcie_bus_info=""0000:C2:00.0"",pod_name="",vdie_id=""3281A66C-0040747A-729D5B72-B9D00485-104301E3""} 800 1758683287482";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}