// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w_]+)(?:\{([^}]*)\})?\s+([\d\\.e+-]+)(?:\s+(\d+))?$").unwrap();
let string = "machine_npu_nums 8
npu_chip_info_aicore_current_freq{container_name=\"\",id=\"1\",model_name=\"910B2-Ascend-V1\",namespace=\"\",pcie_bus_info=\"0000:C2:00.0\",pod_name=\"\",vdie_id=\"3281A66C-0040747A-729D5B72-B9D00485-104301E3\"} 800 1758683287482";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}