import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w_]+)(?:\\{([^\\}]*)\\})?\\s+([\\d\\\\.e+-]+)(?:\\s+(\\d+))?$";
final String string = "machine_npu_nums 8\n"
+ "npu_chip_info_aicore_current_freq{container_name=\"\",id=\"1\",model_name=\"910B2-Ascend-V1\",namespace=\"\",pcie_bus_info=\"0000:C2:00.0\",pod_name=\"\",vdie_id=\"3281A66C-0040747A-729D5B72-B9D00485-104301E3\"} 800 1758683287482";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}