# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\w_]+)(?:\{([^}]*)\})?\s+([\d\\.e+-]+)(?:\s+(\d+))?$"
test_str = ("machine_npu_nums 8\n"
"npu_chip_info_aicore_current_freq{container_name=\"\",id=\"1\",model_name=\"910B2-Ascend-V1\",namespace=\"\",pcie_bus_info=\"0000:C2:00.0\",pod_name=\"\",vdie_id=\"3281A66C-0040747A-729D5B72-B9D00485-104301E3\"} 800 1758683287482")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.