use strict;
my $str = '/testNAS/questions/ask/test/example/picture.png';
my $regex = qr~/(?=[^/\v]*/[^/\v]*$)~mp;
my $subst = '$0;';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";