re = /\/(?=[^\/\v]*\/[^\/\v]*$)/m
str = '/testNAS/questions/ask/test/example/picture.png'
subst = '$0;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result