import re
regex = re.compile(r"/(?=[^/\v]*/[^/\v]*$)", flags=re.MULTILINE)
test_str = "/testNAS/questions/ask/test/example/picture.png"
subst = "$0;"
result = regex.sub(subst, test_str)
if result:
print(result)