#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{4}(?:-\d{2}){2}\s\d{2}(?::\d{2}){2})(,\d+[^\]]+\])\s(INFO|ERROR)\s([\S\s]+?)(?=\r?\n\d{4}(?:-\d{2}){2}|$)"
Local $sString = "2018-01-09 04:50:25,226 [18] INFO messages starts here line1" & @CRLF & _
"line2 above error continued in next line" & @CRLF & _
"2018-01-09 04:50:29,226 [18] ERROR messages starts here line1" & @CRLF & _
"line2 above error continued in next line" & @CRLF & _
"line2 above error continued in next line" & @CRLF & _
"line2 above error continued in next line" & @CRLF & _
"2018-01-09 05:50:29,226 [18] ERROR messages starts here line1" & @CRLF & _
"line2 above error continued in next line"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")