import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}(?:-\\d{2}){2}\\s\\d{2}(?::\\d{2}){2})(,\\d+[^\\]]+\\])\\s(INFO|ERROR)\\s([\\S\\s]+?)(?=\\r?\\n\\d{4}(?:-\\d{2}){2}|$)";
final String string = "2018-01-09 04:50:25,226 [18] INFO messages starts here line1\n"
+ "line2 above error continued in next line\n"
+ "2018-01-09 04:50:29,226 [18] ERROR messages starts here line1\n"
+ "line2 above error continued in next line\n"
+ "line2 above error continued in next line\n"
+ "line2 above error continued in next line\n"
+ "2018-01-09 05:50:29,226 [18] ERROR messages starts here line1\n"
+ "line2 above error continued in next line";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}