const regex = new RegExp('(\\d{4}(?:-\\d{2}){2}\\s\\d{2}(?::\\d{2}){2})(,\\d+[^\\]]+\\])\\s(INFO|ERROR)\\s([\\S\\s]+?)(?=\\r?\\n\\d{4}(?:-\\d{2}){2}|$)', 'g')
const str = `2018-01-09 04:50:25,226 [18] INFO messages starts here line1
line2 above error continued in next line
2018-01-09 04:50:29,226 [18] ERROR messages starts here line1
line2 above error continued in next line
line2 above error continued in next line
line2 above error continued in next line
2018-01-09 05:50:29,226 [18] ERROR messages starts here line1
line2 above error continued in next line`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}