# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4}(?:-\d{2}){2}\s\d{2}(?::\d{2}){2})(,\d+[^\]]+\])\s(INFO|ERROR)\s([\S\s]+?)(?=\r?\n\d{4}(?:-\d{2}){2}|$)"
test_str = ("2018-01-09 04:50:25,226 [18] INFO messages starts here line1\n"
"line2 above error continued in next line\n"
"2018-01-09 04:50:29,226 [18] ERROR messages starts here line1\n"
"line2 above error continued in next line\n"
"line2 above error continued in next line\n"
"line2 above error continued in next line\n"
"2018-01-09 05:50:29,226 [18] ERROR messages starts here line1\n"
"line2 above error continued in next line")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.