import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^\\{\\n])+)(\\{\\{|\\{:)*";
final String string = "abcd\n"
+ "abcd{{\n"
+ "abcd{:efg\n"
+ "abcd\n"
+ "ddddd\n\n"
+ "^((?:.)+)({{|{:)*.*$\n"
+ "^(?:[^{])+)$\n"
+ "((?:[^(?:{|$)])+)({{|{:)*.*$\n"
+ "(?:[^{])+({{|{:|$)*\n\n"
+ "((?:[^(?:{|$)])+)\n"
+ "http://stackoverflow.com/questions/40197545/javascript-regular-expression-match-anything-but\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}