re = /^((?:[^{\n])+)({{|{:)*/m
str = 'abcd
abcd{{
abcd{:efg
abcd
ddddd
^((?:.)+)({{|{:)*.*$
^(?:[^{])+)$
((?:[^(?:{|$)])+)({{|{:)*.*$
(?:[^{])+({{|{:|$)*
((?:[^(?:{|$)])+)
http://stackoverflow.com/questions/40197545/javascript-regular-expression-match-anything-but
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end