import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"(.*?)\"|id=\"(.*?)\"";
final String string = "<pre class=\"code-class\" id=\"code-error\">\n"
+ "function error_notice() {\n"
+ " ?>\n"
+ " <div class=\"error notice\">\n"
+ " <p><?php _e( 'There has been an error', 'my_textdomain' ); ?></p>\n"
+ " </div>\n"
+ " <?php\n"
+ "}\n"
+ "add_action( 'admin_notices', 'my_error_notice' );\n"
+ "</pre>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}