const regex = /class="(.*?)"|id="(.*?)"/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class="(.*?)"|id="(.*?)"', 'gms')
const str = `<pre class="code-class" id="code-error">
function error_notice() {
?>
<div class="error notice">
<p><?php _e( 'There has been an error', 'my_textdomain' ); ?></p>
</div>
<?php
}
add_action( 'admin_notices', 'my_error_notice' );
</pre>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}